LIS Degraded Performance
Incident Report for LifeSouth LIS
Resolved
Issues with degraded performance have been resolved. We continue to monitor performance.
Thank you for your patience. We apologize for any inconvenience this issue caused.
Posted May 19, 2023 - 07:59 EDT
Investigating
We are currently investigating degraded performance. IT is working to resolve.

We apologize for any inconvenience this causes, and are working on a resolution.
Posted May 18, 2023 - 19:20 EDT
This incident affected: Production - LifeSouth LIS Portal.