Incident - Certificate Outage
Incident Report for LifeSouth LIS
Resolved
This incident has been resolved.
Posted May 11, 2022 - 13:54 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 11, 2022 - 13:04 EDT
Investigating
We are currently investigating reports of Users being unable to access the NBTC Member portal.

We apologize for the inconvenience this causes, and are working on a resolution.

Thank You,
The LifeSouth SD Team
Posted May 11, 2022 - 12:37 EDT
This incident affected: Production - LifeSouth LIS Portal.