Incident - Processing delays 11/16/2022
Incident Report for LifeSouth LIS
Resolved
This incident has been resolved.
Posted Nov 17, 2022 - 07:27 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 17, 2022 - 00:07 EST
Update
Investigation into the underlying cause for processing delays continues. Updates will be provided as soon as they are available.

We apologize for any inconvenience this causes, and are working on a resolution.
Posted Nov 16, 2022 - 22:13 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 16, 2022 - 21:02 EST
Investigating
We are currently investigating reports of processing delays.

***The NBTC system will be taken down at 07:20 Eastern for emergency maintenance.***

We apologize for any inconvenience this causes, and are working on a resolution.

Thank You,
The LifeSouth SD Team
Posted Nov 16, 2022 - 19:13 EST
This incident affected: Production - LifeSouth LIS Portal.