Incident - west.nbtc.coop unavailable
Incident Report for LifeSouth LIS
Resolved
This incident has been resolved.
Posted Nov 02, 2023 - 09:14 EDT
Investigating
We are currently investigating reports of the outage of west.nbtc.coop due to an certificate-related issue.
The workaround is to use a non-Chrome browser and choose the "Continue to west.nbtc.coop (unsafe)" option.

We apologize for any inconvenience this causes, and are working on a resolution.

Thank You,
The LifeSouth SD Team
Posted Oct 31, 2023 - 23:57 EDT
This incident affected: Production - LifeSouth LIS Portal.